ExamSoft Support - Chat and Email Outage
Incident Report for ExamSoft
Resolved
The issue impacting ExamSoft Support chat and email channels has been resolved. If you need assistance please resume communication with Support via chat, email, or phone.
Posted Aug 11, 2020 - 15:21 CDT
Identified
The ExamSoft Support team is currently experiencing issues with chat and email. Due to this, we are unable to receive chat or email messages at this time. If you need immediate assistance, please contact ExamSoft Support via phone:

US & Canada: 866.429.8889, ext. 1
International: +1 954.429.8889, ext. 1
Posted Aug 11, 2020 - 14:15 CDT
This incident affected: Support.