Customer Support Phone Incident
Incident Report for ExamSoft
Resolved
While we continue to work with our phone vendor on the root cause, at this time our phones are working as normal and there are no outstanding issues. Thank you.
Posted 5 months ago. Feb 21, 2018 - 00:19 EST
Investigating
We are currently investigating a possible issue with our phone provider. At this time calls are not able to be answered by our support team. Please initiate a chat at examsoft.com/support or email our team at support@examsoft.com.
Posted 5 months ago. Feb 20, 2018 - 23:44 EST