Enterprise Reporting/Scoring
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 03:53 CDT
Investigating
We have currently identified slowness regarding Reporting and Scoring within the Enterprise (New) Portal (ui.examsoft.io).

We will update this post as new information is available.
Posted Sep 08, 2020 - 16:56 CDT
This incident affected: Enterprise Portal (New Portal) Reporting.