Support Updates
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 09:35 CDT
Investigating
Due to higher than normal call volume, our Support wait times are currently longer than usual. If you do not need immediate assistance, we recommend emailing our 24/7 Support Team at Support@examsoft.com.
Posted Sep 03, 2020 - 14:02 CDT
This incident affected: Support.