ExamSoft Support - Longer Than Normal Hold Times
Incident Report for ExamSoft
Resolved
At this time, support call volume and hold times are back within normal range.
Posted 25 days ago. Jan 28, 2019 - 12:17 CST
Identified
We are currently experiencing longer than average support hold times. We are processing calls as quickly as possible. For needs that are not urgent, please email us at admins@examsoft.com.
Posted 25 days ago. Jan 28, 2019 - 11:41 CST
This incident affected: Support.