Slowness on ExamSoft New Portal (ui.examsoft.io)
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 22, 2018 - 10:02 CDT
Investigating
We are currently investigating reports of slowness navigating throughout the ExamSoft New Portal (ui.examsoft.io). This is not impacting Examplify downloads or uploads at this time. We will update this post as new information is available.
Posted 4 months ago. Oct 22, 2018 - 09:38 CDT
This incident affected: ExamSoft Portal (ui.examsoft.io).