Experiencing High Call Volume - Higher than usual wait times
Incident Report for ExamSoft
Resolved
All support services have been returned to normal at this time. We appreciate your patience.
Posted 10 months ago. Dec 04, 2017 - 18:32 CST
Monitoring
We are still getting higher than normal traffic. Please contact us via chat or in the ExamSoft community if you need immediate assistance. You can also email us with less urgent needs at admins@examsoft.com.
Posted 10 months ago. Dec 04, 2017 - 17:46 CST
Investigating
We are currently getting higher than normal support contacts. We are working to resolve issues during this critical time as quickly as possible.
Posted 10 months ago. Dec 04, 2017 - 17:22 CST
This incident affected: Support.