Degraded Support
Incident Report for ExamSoft
Resolved
This incident is now resolved. All support services have been returned to normal at this time.
Posted 10 months ago. Dec 01, 2017 - 18:45 CST
Identified
We are currently experiencing longer than average support hold times and it's possible you could wait for up to 30 minutes to reach a representative. We are processing through calls as quickly as possible. For needs that are not urgent, please email us at admins@examsoft.com.
Posted 10 months ago. Dec 01, 2017 - 18:07 CST
This incident affected: Support.