Support Phone Issue
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Jul 18, 2019 - 15:50 CDT
Investigating
We are currently investigating an issue that is impacting our support phone line. Due to this, we are unable to answer phone calls to support. We are working directly with our phone provider to resolve this issue as quickly as possible, however, if you need immediate assistance, please initiate a chat at examsoft.com/support or email our support team at support@examsoft.com.
Posted Jul 18, 2019 - 15:29 CDT
This incident affected: Support.