Customer Support Phone Incident
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 03, 2018 - 12:29 CDT
Identified
We are currently investigating a possible issue with our phone provider that is impacting our support phone line. Due to this, we have a limited number of support representatives available to answer phone calls to support and support hold times may be longer than normal. We are working directly with our phone provider to resolve this issue as quickly as possible, however, if you need immediate assistance, please initiate a chat at examsoft.com/support .
Posted 7 months ago. Oct 03, 2018 - 12:07 CDT
This incident affected: Support.