Support Phone Line
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 10:54 CST
Update
Due to severe winter storms and declaration of disaster across the state of Texas, ExamSoft Support will close at 8:00 PM CST and reopen at 9:00 AM CST. We will continue to monitor weather conditions and the state electrical grid as operators work to restore power to millions of residents and businesses. Due to this state of emergency, you may experience longer than normal hold times when connecting with ExamSoft Support.

Thank you for your patience and understanding through this unprecedented event.
Posted Feb 16, 2021 - 08:30 CST
Update
We are continuing to monitor for any further issues.
Posted Feb 15, 2021 - 19:33 CST
Monitoring
Due to severe winter storms and declaration of disaster across the state of Texas, ExamSoft Support will close at 8:00 PM CST and reopen at 9:00 AM CST. We will continue to monitor regional weather conditions and the state electrical grid as operators work to restore power to millions of residents and businesses. Thank you for your patience and understanding through this unprecedented event.
Posted Feb 15, 2021 - 08:49 CST
This incident affected: Support.