Issues Accessing Legacy Portal
Incident Report for ExamSoft
Resolved
The exam taker and exam maker portal issue has been identified and resolved. Normal access to the portal should now be available.
Posted Nov 18, 2020 - 08:53 CST
Identified
We are currently investigating intermittent reports of users unable to access the ExamSoft Legacy Portal (www.examsoft.com/yourinstitution). Please note that if a student has previously downloaded an exam, they can start and take the exam without issue.
Posted Nov 18, 2020 - 08:20 CST
This incident affected: Legacy Portal (examsoft.com/institutionid).