Issues with Accessing Legacy Portal
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 12:08 CDT
Investigating
We are currently investigating intermittent reports of users unable to access the Legacy ExamSoft Portal (www.examsoft.com/yourinstitution).

Please note that if a student has previously downloaded an exam, they can start and take the exam without issue. Once they close an exam, it is safely stored on their hard-drive and will be uploaded. We will update this post as new information is available.

For applicants taking the bar exam, the exam passwords can be accessed at https://bar.examsoft.io/jurisdictionID.
Posted Oct 05, 2020 - 10:25 CDT
This incident affected: Legacy Portal (examsoft.com/institutionid).