ExamSoft Legacy Portal Slowness
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 19, 2018 - 12:34 CDT
Investigating
We have identified an issue causing slowness in the portal and issues logging in to the ExamSoft legacy portal. This is only affecting some users at this time. Examplify registration, download, or upload is unaffected.
Posted 7 months ago. Apr 19, 2018 - 12:25 CDT
This incident affected: Legacy Portal (examsoft.com/institutionid).