Customer Support Phone Incident
Incident Report for ExamSoft
Resolved
Our VOIP vendor has confirmed that this service issue has been resolved.
Posted about 1 year ago. Nov 02, 2017 - 12:40 CDT
Investigating
ExamSoft's VOIP provider is currently experiencing service degradation. Callers to the ExamSoft Support queue may experience dropped calls, inability to hear the support agent, or lengthy hold times.
Posted about 1 year ago. Nov 02, 2017 - 11:27 CDT
This incident affected: Support.