Sporadic slowness throughout New ExamSoft Portal (ui.examsoft.io)
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted 5 months ago. May 24, 2018 - 14:29 CDT
Investigating
We are currently investigating some reports of slowness throughout the New ExamSoft Portal (ui.examsoft.io). It appears to be sporadic at this time, however, we are working on resolving this as quickly as possible and will update this page as additional information is made available.
Posted 5 months ago. May 24, 2018 - 13:41 CDT
This incident affected: ExamSoft Portal (ui.examsoft.io).