Support Degraded Performance
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted May 30, 2023 - 08:03 CDT
Investigating
Our internal support agents are currently experiencing technical difficulties accessing some client information in the Legacy Portal. We are investigating this issue and working on a fix. Please refer to status.examsoft.com for updates.
Posted May 29, 2023 - 14:37 CDT
This incident affected: Support.