Enterprise Latency

Incident Report for ExamSoft

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 12:48 CST

Investigating

We are receiving reports of errors and Latency with our Enterprise portal. At this time, we understand that this is impacting your ability to Navigation, push grades, and log in with the Enterprise portal. We are currently investigating these reports in order to restore services to normal and will take swift action if an issue is identified.
Posted Feb 07, 2025 - 12:07 CST
This incident affected: Enterprise Portal (ui.examsoft.io).