Support Phone Line Outage
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 16:03 CDT
Investigating
We are currently investigating an issue that is impacting our support phone line. Due to this, we are unable to answer support phone calls at this time. We are working directly with our phone provider to resolve this issue as quickly as possible, however, if you need immediate assistance, please initiate a chat at examsoft.com/support or email our support team at support@examsoft.com.
Posted Sep 28, 2022 - 11:55 CDT
This incident affected: Support.