Legacy Portal-Posting Error Message
Incident Report for ExamSoft
Resolved
Thank you for your patience! This has been resolved.
Posted Apr 09, 2021 - 15:02 CDT
Investigating
We are currently investigating reports of users experiencing error messages when attempting to post exams to ExamSoft Legacy Portal.

We apologize for any inconvenience as we work to resolve this matter. Thank you for your understanding!
Posted Apr 09, 2021 - 13:57 CDT
This incident affected: Legacy Portal (examsoft.com/institutionid).