Support Hold Times

Incident Report for ExamSoft

Resolved

This incident has been resolved.
Posted Nov 01, 2023 - 15:41 CDT

Monitoring

We are currently experiencing higher than usual wait times. We appreciate your patience. For non-urgent needs, please email us at the examsoft-support@turnitin.com email address.

To ensure customers are being assisted appropriately, chat support hours have been modified. The chat hours of operations are from 6pm Central to 7am Central.
Posted Aug 28, 2023 - 13:33 CDT
This incident affected: Support.