ExamSoft New Portal (ui.examsoft.io)

Incident Report for ExamSoft

Resolved

The issues affecting Enterprise Portal have been fully resolved. Users should no longer experience any issues logging in or accessing the platform.

We apologize for the disruption and appreciate your patience while we restored service.
Posted Aug 17, 2026 - 10:05 CDT

Investigating

We are currently investigating reports of inability to access the Enterprise Portal (ui.examsoft.io). We will update this post as new information is available.
Posted Aug 17, 2026 - 09:36 CDT
This incident affected: Enterprise Portal (ui.examsoft.io).