Examplify Downloads Impacted & Portal Slowness
Incident Report for ExamSoft
Resolved
We are pleased to advise that services have been restored.
Posted Jun 24, 2022 - 08:50 CDT
Investigating
We’ve run into some issues.

Examplify and the Enterprise portal is currently experiencing an unexpected service disruption.

During this time, you may find that exams may not download and overall navigation slowness in portals.

Please refer to this status page on all progress regarding this incident while we work to bring the service back to optimum health.
Posted Jun 24, 2022 - 08:36 CDT
This incident affected: Enterprise Portal (ui.examsoft.io) and Examplify Services.