Examsoft.com Domain is currently down.

Incident Report for ExamSoft

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:25 CDT

Investigating

We are currently investigating an issue where the www.examsoft.com URL is not working appropriately. As we continue to investigate and review this issue, please utilize the https://apps.examsoft.com/ URL to log into your institution environment. For all updates on this issue, please go to the status.examsoft.com website and subscribe.
Posted Jun 12, 2025 - 13:44 CDT
This incident affected: Legacy Portal (examsoft.com/institutionid) and Enterprise Portal (ui.examsoft.io).