Phone Support Currently Unavailable

Incident Report for ExamSoft

Resolved

We are pleased to advise that service has been restored, we regret any inconvenience this may have caused if you were impacted by today’s incident.
Posted Apr 23, 2026 - 05:36 CDT

Investigating

We are currently experiencing technical issues with our phone lines.
To ensure you receive timely assistance, please use our alternative support channels:

Live Chat: Visit our Help Center (https://support.examsoft.com/hc/en-us) and click the chat icon located at the bottom right corner of the screen.
Email: Reach out to our team directly at support@examsoft.com.
Posted Apr 23, 2026 - 03:36 CDT
This incident affected: Support.