Support Huge Call Volumes
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted May 23, 2022 - 14:06 CDT
Identified
We are currently experiencing abnormally high volumes in support. If you are contacting support due to NYUBE deadlines, please log into your www.examsoft.com/nyube portal to confirm your ExamSoft registration. If you have uploaded your mock exam and downloaded your bar exam files you are registered. Please check your inbox for updated information regarding your bar registration.
Posted May 23, 2022 - 11:45 CDT
This incident affected: Support.