US Enterprise Portal Scoring Degradation
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 19:21 CDT
Investigating
The US Enterprise portal is currently experiencing issues loading scores for assessments. The issue has been identified and scoring of assessments should resolve within an hour. If the assessments did not score after a couple of hours, please refresh the page. For additional updates, please subscribe to the status.examsoft.com website.
Posted Oct 08, 2024 - 18:17 CDT
This incident affected: Enterprise Portal (New Portal) Reporting.