Enterprise portal degraded performance

Incident Report for ExamSoft

Resolved

The issue affecting the Enterprise Portal has been resolved.
Posted Sep 15, 2026 - 17:01 CDT

Monitoring

Enterprise users should now see improved response times and normal site speed.

We are currently monitoring to verify that no additional issues arise.
Posted Sep 15, 2026 - 15:03 CDT

Investigating

We are investigating reports of degraded performance affecting the Enterprise Portal. Some users may experience errors or intermittent slowness when accessing certain portal functionality

We will share updates here so you can track our progress while we resolve the issue.
Posted Sep 15, 2026 - 14:01 CDT
This incident affected: Enterprise Portal (ui.examsoft.io) and Enterprise Portal (New Portal) Reporting.