ExamSoft Enterprise Portal (ui.examsoft.io)
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 10:00 CST
Investigating
We are currently investigating reports of slowness navigating and issues loading certain pages within the Enterprise Portal (ui.examsoft.io). We will update this post as new information is available.
Posted Dec 04, 2019 - 09:41 CST
This incident affected: Enterprise Portal (ui.examsoft.io).