Support Degraded Performance
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted May 16, 2022 - 10:03 CDT
Investigating
ExamSoft support is experiencing a partial outage of some capabilities including chat. ExamSoft Support services such as email and phone support are currently online. While services are down, please refer to our community articles and guides for additional assistance at the https://community.examsoft.com/s/ website.
Posted May 16, 2022 - 06:28 CDT
This incident affected: Support.