Enterprise Portal unable to finalize assessments
Incident Report for ExamSoft
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 14:48 CDT
Investigating
Currently we are investigating an issue where administrators are unable to finalize their assessments in the Enterprise portal. The current workaround is duplicating the assessment and/or modifying download start/end times to an even further range. Please subscribe to the status page for any additional updates.
Posted Apr 10, 2024 - 14:29 CDT
This incident affected: Enterprise Portal (ui.examsoft.io).